Starting Point System : Forum

You are not logged in.

#1 2010-03-15 15:13:08

New member

LabView Interface Problem

OK,I have gotten the Cameleon up and running with the provided test software so I know it is working ( I can hook up a variable voltage source to pin 1 and see a variable output on the scale for pin 1).  Now I'm trying to read the same data through Labview and I get almost nothing.  Sorry but I'm fairly new to Labview and have never read data from a serial source (with the VISA vi's).

I set up the Cameleon and both the Measurement and Automation Explorer and my VI see the Cameleon but neither one seems to read any data whatsoever.  My VI simply times out with no bytes received.  I'm sure its something dumb on my part but is there any LabView people out there that can point me in the right direction?




#2 2010-03-15 22:58:03


Re: LabView Interface Problem

Hi, I dont use LabView... I'm programming a C# auto-timescheduler for uChameleon... What I could tell you is:

1- you need \r\n after all command to be sent to uChameleon
2- for reading values from it, you need istructions to take data string from the Virtual COM Port buffer, it's not automated... if you have a block in MatLab for the Com Port search for a possible command to pull data from the buffer.

If you want to know the buffer dimension go in Control Panel, System and open the Properties of the uChameleon COM Port.

I hope it will help...

Last edited by gremlinc5 (2010-03-16 16:49:51)

ST7FLite39 daughter board
REva 2.10
RLink 3.4
"uChameleon" as: SPI Master for debug, Analog output for sensing emulation



#3 2010-03-16 21:08:08

New member

Re: LabView Interface Problem

Thanks Gremlin

The \r\n seams to be what I was missing.

Now I have to see what data I really get so I can seperate out my string data from Cameleon.

Scott V



#4 2010-05-10 23:49:12

New member

Re: LabView Interface Problem

Hello ScottV

I don't know if you have solved your problem, but I have seen this problem (in the beginning as I am new to LabVIEW and learning by doing) of measuring DC (Analog) voltage too.
Here are some tips:
1: Download the example of GenLAB from the starting point systems.
2: extract all the files from the downloaded directory to a new folder.
3: launch "GenLAB Main 01 for LV2009"

When you lauch, and had already connected your DAQ to COM (in my case it is COM4) port, there will be a messege when you run this VI, to select the Áchameleon. When you select that, afterwards there will be another window asking (might be automatically) about VISA resource (on the left top corner). There you scroll down and click the selected COM and click Configure.

After configuration, you are automatically on the front panel. Here you should click "Enable A.I" and "5Volt Scale".

Well, that's it!

Give some test source voltages to input pins1-4 and measure it on the chart.




#5 2010-05-13 16:00:13

New member

Re: LabView Interface Problem

Thanks for the reply.  I did get through my initial problem and was able to make up a VI using the VISA call outs that worked.  Unfortunatly, until recently I did not hav ethe GenLab project to look at as it was a version 9 format and my latest version is 8.5.  I did get the GenLab re-saved to an 8.5 compatible format and can now look at it when I get some time.  If anyone else needs the GenLab in 8.5 let me know an I will email it to you.

Now if I can get more time to do some of this fun stuff rather than the day job, it will be all right.




Board footer

Powered by FluxBB